Log in with:

Forums

Broken clue making me angry!!!

Quick find code: 21-22-677-64519432

of 2
Against Fate

Against Fate

So i have a clue that says Think under the lens in the Observatory. Twirl before you talk to me. Equip a mithril chain body, green dragonhide chaps and a ruby amulet. I did did the thinking emote under the lens of the telescope a million times wearing the 3 required items and Uri never shows up, did the observatory quest and had to lvl all my skills so i could wear the items which took up about 2 hours. I do clues all the time on EoC and now on 07 scape this bs happens. What am I doing wrong?

09-Mar-2013 20:27:07

Orwells

Orwells

I have the EXACT same problem.
But the clue in 2007 doesn't say that,
It says this:
Think in the centre of the Observatory.
Spin before you talk to me.
Equip a Mithril chain body, green dragonhide chaps, and a ruby amulet.

Doesn't work at all.

10-Mar-2013 09:42:16

Giant dwarf
Feb Member 2015

Giant dwarf

Got this clue earlier, same problem, I've tried literally everything, completed the Observatory quest and so on.

11-Mar-2013 16:01:32

A7X vs ATR

A7X vs ATR

Same problem also. Would be nice to find some sort of solution for this....

11-Mar-2013 17:25:13

Orwells

Orwells

I "solved" it

link to pic:
(replace "***" with "***")

http://bases.roflbot.wigflip.***//E/E/9S3oO7gZVR.jpg

12-Mar-2013 16:54:56

Sam M

Sam M

Just look at my thread. I explained it.

Quick find code: 21-22-489-64570153

12-Mar-2013 17:39:20 - Last edited on 12-Mar-2013 17:40:26 by Sam M

MisFix

MisFix

same them links dont work this clue is annoying me to the angry point of donno just fix it please

26-Mar-2013 01:28:05

zyar0

zyar0

I have the same problem this is very irritating fix it already!

29-Mar-2013 16:32:37

Amamma2

Amamma2

Guys i made it work im sorry i dont have a screen shot but do the emote think on the south west side of the mid floor not the top! ok hope i helped.

01-Apr-2013 08:41:59

Quick find code: 21-22-677-64519432Back to Top